APM: large gaps in data
Incident Report for Scout
Resolved
We've restored all the historical data that was temporarily not showing up on charts. If you have any questions about this incident, drop us a support email.
Posted Nov 05, 2015 - 09:10 MST
Identified
InfluxDB has established how to recover the missing 7-day data. We will begin data recovery tomorrow. I the mean time, Scout APM is operational, and new data over the last 12 hours is present and unaffected.
Posted Nov 02, 2015 - 21:02 MST
Update
We're still working with our timeseries database provider to rectify the data gaps.

Late this morning, all the nodes in our influxDB cluster consumed all the RAM on the boxes within 1 minute of each other and were bounced by monit.

Data from before the out-of-memory restarts is still on disk but not query-able. InfluxDB core development is trying to determine why the older data is not being returned.
Posted Nov 02, 2015 - 15:23 MST
Update
We're working with our timeseries database provider to resolve the data gaps. We'll update as we have more information.
Posted Nov 02, 2015 - 11:29 MST
Investigating
We're seeing large gaps in metrics with app monitoring and are investigating.
Posted Nov 02, 2015 - 10:26 MST